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Attention MS-Access users....
If you produce your reports via MSAccess, you must ensure that the reports are saved in ASCII text 
format.    After you run the report with MSAccess, choose 'Output To' from the MSAccess File menu.   
Then select 'MSDOS Text'.    In the dialog box, specify the file name and press OK. 



Copyright, Registration, Technical Support

This system was developed by Informatik Inc, P.O. Box 868, Devon, Pennsylvania 19333.    For 
information on program modifications, systems integrations and custom applications, please contact 
Informatik Inc.

This is a copyright-protected shareware product.    If, after review and evaluation, you like the 
software, please register.    Shareware is based on trust, and we hope that all users will register.    
Upon registration and payment of the registration fee, Informatik Inc will send you the latest master 
diskette, a registration certificate and a User Guide.    Registered users will receive technical support 
and software upgrades as specified in the application.

To register

From the About menu, choose 'Registration, Copyright, License' and follow the instructions.

To obtain technical support

From the Help menu, choose Technical Support and follow the instructions.

Infothek is a trademark of Informatik Inc.

© 1994-1995 Informatik Inc
All rights reserved



Add    a Report, Index a Report, Remove a Report

See also Index Specifications    

The indexing of reports is optional; indexing is only required if you want to create sub-indexes for 
(hierarchical) groups and sections of a report. Non-indexed reports can be viewed as easily and 
quickly as indexed reports.

To index a report

Your reports must be in MS-DOS text format.    Most report generators allow you to save the reports 
in the text format.  Attention MS-Access users:    If you produce your reports via MSAccess, you 
must ensure that the reports are saved in ASCII text format.    After you run the report with 
MSAccess, choose 'Output To' from the MSAccess File menu.    Then select 'MSDOS Text'.    In the 
dialog box, specify the file name and press OK. 

1. Organize the report print files into specially designated directories (for example functional 
classification, time periods, etc.).    This step is not absolutely required, but strongly 
recommended.

The base name of the report file always becomes the    root index (main index) name.    If the 
base name of the report file is not appropriate, change the file name in the Windows File 
Manager (File | Rename) before you index the reports.

2. In the Drive list and Directories list, specify the drive and directory of the reports (the directory 
name must be double-clicked).    You can filter out specific files with an entry in the Pattern field.   
In the Files list, highlight the report that you want to index.

3. Click the Create Index button, or choose Index Report from the File menu.    The On-line Index 
Specification window is displayed.

4. The system displays the first 30 lines of    the report.    If index specifications are embedded in the
report or exist in the index specification file, they are shown as default entries.    If you want to 
change the specifications, choose the Clear button.

5. In the text of the displayed report, highlight the static label of the first group heading that you 
want to index (including any colons) and press the Paste button.    If no errors are detected the 
index parameter is inserted in the Index Profile field above.    Repeat the process for each 
hierarchical index level, in the correct descending order.    If you make a mistake, press the Clear
button and start over.    

 6. Review the index profile.

7. To save the index profile in a IXS file, choose Save Index Profile from the File menu.    The 
system creates an    index profile file in the applications directory.    The base name of the new file
is the base name of the report file, with an extension IXS.    If the file already exists it is 
overwritten without warning.    

8. To index, choose OK Create.



To remove a report file from the index

The index files are saved in the same directory as the print files.    The extension name of the index 
specifications is XRD.    To remove an index, use the Windows File Manager.    If you re-index a 
report, the old index file is overwritten.



Basic Concept

E:report is a report indexing, filing and retrieval system. The indexed report files must be in a 
standard 'print file' format.

The system is ideally suited for computer generated management reports.    These reports often 
consist of hierarchical groups, sections and sub-sections, such as divisions, departments, 
geographical areas, etc. 

The reports must be in MS-DOS Format.    Most report generators let you save the reports in text 
format.    Attention MS-Access users:    If you produce your reports via MSAccess, you must 
ensure that the reports are saved in ASCII text format.    After you run the report with MSAccess, 
choose 'Output To' from the MSAccess File menu.    Then select 'MSDOS Text'.    In the dialog box, 
specify the file name and press OK. 

The indexing of reports is optional; indexing is only required if you want to create sub-indexes for 
(hierarchical) groups and sections of a report.    Non-indexed reports can be retrieved and viewed 
equally fast.    The print file base name must be unique within the directory.

The indexes are created by the system.    The system only needs to know the first complete set of 
indexes, as a sample.    The system then evaluates the context of the sample and locates and 
creates all indexes for the report (Indexing-by-Example).    See Index Specifications.    

A word relating to headings and labels.    Each group or sub-group in the report must have a 
heading.    The heading must be positioned on its own line (or it must be the first text on the line).    
The heading has two parts: a)    a static label and b) the variable heading information.    The heading 
must be consistently positioned on the line.    In the following examples of headings, 'Division:' and 
'State:' are the static labels, 'Mid West' and 'Wisconsin' are the variable elements of the heading: 

Division: Mid West
State: Wisconsin

The index files are saved in the same directory as the print files under the print file's base name, with
the XRD extension.    Only one index file can exist per base name in a directory, therefore, all print 
files with a common base name use the same index.    The index file has a    'System' file attribute 
and may not be visible in the file directory.

The reports can be retrieved and viewed on the screen, or they can be printed.    Sections of reports 
can be copied and pasted    (via Clipboard) to virtually any Windows application, such as 
spreadsheets or word processors.    The system can convert raw print text into    tab-separated 
columnar formatted text.    

The system also features a word search function.

See View and Print a Report, Copy to Clipboard, Search

E:report includes a limited password security system.    The access to sections of reports is 
controlled by    the hierarchical structure.    Therefore, a person authorized to view a particular level of
report data can view all the subordinated levels as well.    See Security and Passwords

Limitations



There is a limit of nine (9) hierarchical index levels.

The first occurrence of each class of indexed heading must be within the top 30 lines of the report.

Only one index can exist on a printed line.    The index heading should be on its own line, and there 
must be no variable report data to the left of the index heading label.

The base name of the print file must be unique within the directory, regardless of the extension 
name.

The search function is limited to 32,000 lines of text at one time.

                                              
                                  



Exit

To exit system

From the File menu, choose Exit System.



View and Print a Report, Copy to Clipboard,    Search

Reports can be viewed, printed and copied to the Windows clipboard. 

To view a report

1. In the File Selection window, specify the directory (double click) and select the file name (double 
click).    If the report has an index, the outline in shown in the List of Reports below.    If no index 
exists, the text of the report is displayed in the Report window. 

2. In the Report Outline, click the report name (topic).    If the item has a plus sign (+), the report 
consists of indexed sub-sections.    To see the sections, click the plus sign.    The outline expands
and shows the next level of indexed sections and the plus sign changes to a minus (-) sign.    If 
there are plus signs on the next hierarchical level, the section can be split into smaller sections, 
and so on.    Select the section you want to view.    To collapse the expanded list, click the minus 
sign. 

Only the reports for which you have password clearance are listed.

Please note that a person with security clearance to a given hierarchical level, can also access 
the subordinate levels.

3. The (section of the) report is displayed in the window on your right. 

If the report does not fit on the screen, a vertical scroll bar is added.    Use the scroll bar to move 
forward and backward.    The arrows at the top and bottom of the scroll bar move the visible text 
by one line.    The scroll box (also called thumb) between the arrows moves the visible text 'non 
stop' to any screen page, including first page and last page.    You may also use the PgUp, PgDn,
Home and End keys

A horizontal scroll bar allows you to view extra wide reports.    Click the shaft area of the 
horizontal scroll, or drag the report window.    Double-click the report to reset the window to its 
home position.    Alternatively, maximize the Report window by double-clicking the title bar of the 
Report window.    

To change the size of the display font, choose the font point from the View menu.

Wide reports can also be split into two sections.    A split window allows you to view two 
separate areas of the report. To split the report, choose Split Report from the View menu.    You 
can scroll, re-size and slide the split section.    To re-size the split section, simply drag the right 
hand border.    To slide the split section, place the cursor inside the section and drag it 
horizontally    The split can be undone by choosing Split Report from the View menu.

To print a report, to copy to the clipboard

From the File menu, select Print Report.    Select the printer (if required), specify the number of 
copies and press OK.    

There are two methods of printing.    The Print Report (Raw) prints the report file 'as is' .    The 



standard Print Report adds page breaks and page numbers when printing.

You may also copy selected text and paste it to the Windows clipboard.      For the copy 
functions, choose the Copy menu.

There are two methods of copying text to the Clipboard.    The Copy to Clipboard (As Is) copies 
the selected text unaltered.    The Copy to Clipboard (Tab Format) converts standard print text 
into a tab-separated format suitable for spread sheets.    See Export    to Clipboard

To search for a word

You can search for a word,    part of a word, or word combination.    All searching is performed 
'moving forward'.    Only the text for which you have password clearance will be searched.    
Searching a very large file may take a considerable time.    The search is limited to 32,000 lines of 
text.

1. Display the report.

2. Choose Search Forward from the Search menu.    

3. In the prompt, enter the character pattern.    The characters are case sensitive; upper case and 
lower case characters are not interchangeable.    Wildcard characters are not permitted.    
Choose OK.    

The system displays the first match of the pattern, starting from the highlighted text or from the 
top of the current screen.    

4. To search for the next word match, choose Search Next from the Search menu (or press N + 
Ctrl).



Index Specifications

See also Index a Report

The indexing of reports is required only for hierarchical groups and sub-groups of the reports.    Index
specifications are shared by all print files with a common base name (in the same directory).    
Reports without indexes can be retrieved and viewed as a whole report.

Indexes can only be created if the following conditions are met:

a) The report file has a hierarchical structure and the report groups have consistent headings.    
The group headings must be on separate lines (or must be the first text on the line) and they 
must include a static (constant) label and a variable label information element.    For 
example, 'State:' is the static label and 'Texas' is the variable element.    A consistent context 
of the heading is essential; the leading and trailing spacing of the static label, its placement 
relative to the left border, and its exact spelling must be applied uniformly throughout the 
report.

b) Index Profiles are supplied to the system. 

An index profiles must be specified for each type of report.    On the displayed report, simply highlight
the first heading label of each hierarchical level; the system then creates the index file for the whole 
report (Indexing-by-Example).    The index profiles can be saved on disk and used as default index 
profiles for other reports with the same base name (across directories).    

The index profile can also be embedded in the text of the report.    If embedded, the profile text line 
must be placed after the reports' header and before the first index item.    The embedded profile text
must be prefixed with a *IXS* flag (see example of report below)

The index profile specifications are case sensitive.    Leading, embedded and trailing spaces are 
significant.

Recommendations to minimize indexing errors

1. Report sub-headings should include a non alpha symbol, such as colon.    This will make the 
indexes more unique and less susceptible to name conflicts.

2. When embedding the index specification    in the report file, ensure that the specification is 
inserted after the report's heading.

3. Remember that the index is case sensitive.    An upper-case 'A' is not matched against a 
lower-case 'a'.    Also,    spaces are significant.    

4. Ensure that the report headings are consistent.    They must be on separate lines (or they 
must be the first text on the line) and the heading must include a static label and a variable 
element.

5. Never change a report file after it has been indexed.



Example of a simplified report

XYZ Corporation
Sales Report
December 31,1994

*IXS*Division:;State:;Sales Person:

Division: North East
State: New York
Sales Person: J    Smith

.... report data .............

Sales Person:  A Miller

.... report data .............

State: Pennsylvania
Sales Person: R Anderson

.... report data .............

Sales Person: D Cook

.... report data .............

Division: South East
State: Florida
Sales Person:  J Hopps

.... report data .............

.



Security and Passwords

Please read the Manual for Systems Administrators.



Tutorial

This tutorial shows you how to create report indexes, retrieve and view the reports.    The tutorial 
uses sample reports which are included in the software files.

It is suggested that you print out the text of this tutorial and follow the process step by step.    To print 
out this tutorial, choose Print Topic from the Infothek Help system's File menu.

 1.  We will index only one report file (AASALES.SPL)      This sales report is suitable for multi-level 
hierarchical indexing.

2. In the Directoriy list, select the directory that holds the sample report files (the directory of the 
application, such as C:\EREPRT).    Double-click the directory name.    All files contained in the 
selected directory are displayed in the Files list.    For our tutorial, we only want the sample files 
with the SPL extension name.    In the Pattern field, type *.SPL.    The Files list now displays three
files (aasales.spl, balsheet.spl and income.spl).

 3. Select the aasales.spl file.    
 
 4. Click the Create Index button, or choose Index Report from the File menu.    The On-line Index 

Specification window is displayed, complete with an extract of the top section of the report. 

 5. In the report text below, highlight the word 'Division:" (including the colon).    This is our first and 
top-tier index parameter.    Press the Paste button.    The index parameter is pasted to the Index 
Profile field above.    Highlight the second index parameter, i.e. State: and press the Paste 
button.    Repeat the process for the third index parameter, i.e. Sales Person:

6. Press the OK Create button.    The system creates the indexes.

7. Back in the File Selection window, select the directory (double click) and select the 
AASALES.SPL file (double click)    You will find it in the application's directory.    An outline of the 
report file is displayed in the Report Outline list.    Click the plus sign (+).    The outline expands 
and discloses the next subordinated level of report sections. 

In the Report Outline, click the description (topic) of the report; the respective (section of the) 
report is displayed in the window on your right.    Click on the topic of another report line and view
another report section.

To contract (collapse) the list, click the minus sign (-).

 8. Now, let us view a non-indexed report.    Specify the directory ( if not already selected) and 
double-click the INCOME.SPL file.    Because the report does not have sub-indexes, it is NOT 
listed in the Reports Outline below, but the text of the report is displayed in the Report window.    

9. If the report does not fit on the screen, a vertical scroll bar is added.    Use the scroll bar to scroll 
forward and backward.    The arrows at the top and bottom of the scroll bar move the visible text 
by one line.    The scroll box (also called thumb) between the arrows moves the visible text to any
chosen location, including the first page and last page. You may also use the PgUp, PgDn, 
Home and End keys.

A horizontal scroll bar allows you to view extra wide reports.    Click the shaft area of the 



horizontal scroll, or drag the report window.    Double-click the report to reset the window to its 
home position.    Alternatively, maximize the Report window by double-clicking the title bar of the 
Report window. 

10. Wide reports can be split.    This allows you to view the stationary left side of the report with 
selected other parts of the report.    The stationary left side can be moved and scrolled.    To split 
the report, choose Split Report from the View menu.    

11. To copy a section of the report to the clipboard (so that you can use it in other Windows 
applications, such as spreadsheets or word processors),    select some rows with your mouse.    
Then, from the Copy menu, choose Copy to Clipboard (As Is) or Copy to Clipboard (Tab Format).
The first option copies the text 'as is', the second option converts the text to a tab-separated 
columnar format for spreadsheets.

12. To print a complete report or highlighted selections, choose Print Report from the File menu.    
When printing a section only, ensure that you highlight the section first.

13. To create a new file for the selected report (or section of report), choose Save As from the File 
menu.    Specify the file name and choose OK.

14. To exit the system, choose Exit System from the File menu.

Attention MS-Access users

If you produce your reports via MSAccess, you must ensure that the reports are saved in ASCII text 
format.    After you run the report with MSAccess, choose 'Output To' from the MSAccess File menu.   
Then select 'MSDOS Text'.    In the dialog box, specify the file name and press OK. 

 



Export to Clipboard

Sections of the report can be exported to the Clipboard.    From the Clipboard, the data can then be 
pasted to spreadsheets and other Windows applications.    The export program can convert the text 
of most reports into a 'tab-separated' format.    Only the text appearing on the screen can be selected
for export (no scrolling).

To export data to the Clipboard

1. On the Report in the Reports window, highlight the rows that you want to export.    Always select 
complete rows.

2. From the Copy menu, choose Copy to Clipboard (As Is) or Copy to Clipboard (Tab Format).

3. Activate your recipient spreadsheet or other Windows application.    

4. From the Edit menu of    your spreadsheet or other Windows application, select Paste.

5. Review the data.



Data Compression

The print files can be compressed.    Although the compression algorithm is not optimized, the file 
size can be reduced significantly with file compression.    The compression program must be run 
before   the reports are indexed  . 

To compress a file

1. Select the file.

2. From the File menu, choose Compress/Decompress File | Compress File.    The Save As dialog 
box appears.    

3. Specify the new file name of the compressed file (you must not use the original file name).    The 
system does NOT require a specific extension name for compressed files.

4. Choose OK.

To decompress a file

The decompression of a file is performed by the system whenever data is displayed or printed.    To 
decompress a file, you may also use the Decompress function in the Compress/Decompress menu.

Compression algorithm

Only spaces are compressed.    The contiguous number of spaces must be 4 or more.    The 
compressed space is replace by a caret symbol (^) followed by a numeral indicating the number of 
spaces.    For 4 to 39 spaces, the numeral immediately follows the caret symbol (without a space).    
For more than 39 spaces, a space is inserted before and after the numeral.    Examples:    ZZZ^8ZZZ
= 8 spaces between the letters ZZZ; ZZZ^32ZZZ = 32 spaces; ZZZ^ 123 ZZZ = 123 spaces (notice 
the space before and after the 123.

Indexing Considerations

When indexing a compressed report, always include the caret and the numeral as part of the 
heading label.                    




